Carregando Legendas no Windows Media Player 9

Eu costumava utilizar alguns softwares específicos para poder ver videos com legendas em formato SRT, até que meu amigo (Denial) me falou de um jeito muito mais fácil. Basta adicionar o suporte a legendas no Windows Media Player. Para isso:

  1. Baixe aqui o arquivo vsfilter_XXXXXXXX.zip;
  2. Descompacte e mova o arquivo VSFilter.dll (da pasta Release) para o diretório C:\Windows\System32;
  3. Entre no prompt de comando (Iniciar -> Executar -> cmd);
  4. Entre no diretório do system32:
    cd C:\Windows\System32
  5. Registre a DLL:
    regsvr32 vsfilter.dll

Um detalhe importante é que o nome do arquivo da legenda deve ser o mesmo do video.

Depois de tudo configurado, basta abrir o video no Windows Media Player e a legenda será carregada automaticamente. Você poderá notar que aparecerá um ícone com uma seta verde ao lado do relógio. Clicando sobre ele, você terá acesso a várias opções para configuração das legendas, inclusive permitir que esta aplicação seja carregada automaticamente quando não houver legenda compativel (com o mesmo nome do video), permitindo assim que você possa carrega-la de outro lugar (ou com outro nome).

?? importante lembrar que o uso dessas legendas são para videos que você tenha feito ou que tenha o direito de usá-lo e não para videos com copyright baixados da Internet.

Posts relacionados:

50 thoughts on “Carregando Legendas no Windows Media Player 9

  1. olá,
    parece muito simples. mas, funciona mesmo? no XP por exemplo?

  2. humm.. acho que sei o que aconteceu no seu caso Eduardo, você deve ter descompactado o arquivo diretamente para o c:\windows\system32, assim ele cria duas pastas: Release e Release Unicode. O que você pode fazer é entrar no diretório c:\windows\system32 e digitar o comando
    copy Release\VSFilter.dll .
    Assim você estará copiando o arquivo VSFilter.dll para o diretório correto: c:\windows\system32

  3. olá, tudo bem?
    etnãi. tá certo eu copiei o arquivo para dentro do pasta que vc disse. eu acho que deve ser pq estou com a versão 10 do mplayer. vou ver se tem um vsfilter mais novo que o que eu abaixei…

  4. olá – segui todos os passos e coloquei o arq. dll dentro do c:wnidows\system32 e tb do d:windows\system32 pa tenho dois sistemas. Mas não apareceu aquela setinha q vxc disse q apareceria e nem legendas. O q há de errado. vlw.

  5. Amigos , sim senhora , inpressionado , resultou mesmo , devo_te uma , andei imenso tempo atraz de algo q fizesse milagre e ele apareceu , tao simples tao facil , e dá granda geito , obrigadao manos , já agora sabem como por as mesma legendas no nero7 premiun? agradeco quem deixe uma dica, abraços..

  6. Neto, quando vi sobre o WMP pensei que fosse o que estou precisando, mas não é.
    Eu tenho um pentium 2 (266 mgh) com WMP 9, quando baixo músicas pelo emule e depois vou gravá-las os nomes não saem corretos: saem com letras minúsculas, o ç sai como x e as letras com ~ saem como t, e outras coisas mais…não sei como mudar isso e já perguntei pra várias pessoas e nínguem sabe como alterar para que quando gravadas no cd aparecem com a nomenclatura correta. Gostaria muito de sua ajuda…não sei se por aqui você irá me atender, mas não sei por onde devo te perguntar estas coisas.
    De qualquer maneira, muito obrigada pela a atenção e aguardo “se possível” sua resposta.
    Rosana.

  7. Rosana,

    Este problema não tem nada a ver com seu Modem (conforme e-mail enviado) e nem com o WMP em si. Se as músicas após download estão armazenadas com os nomes corretos no seu disco, o problema pode ser da aplicação utilizada para gravar o CD. Se após o download elas já possuirem o nome errado com certeza o problema está no e-mule, ou do sistema operacional que você está utilizando.

    Problemas com caracteres acentuados, normalmente tem a ver com a codificação (encoding) utilizada entre as diversas aplicações (UTF-8, ISO-5589-1).

    Neto

  8. Neto, geralmente as músicas vem com o nome errado(principalmente acentuação), eu corrijo em minha pasta de armazenamento e no WMP e uso para gravar o B’s Recorder Gold 5 (da Sony)……realmente não sei o que fazer…..quanto a codificação (encoding) eu não entendo. Você acha de eu tenha que fazer algum tipo de reconfiguração? Como faço isso? O sistema operacional que uso é o Windows 98 SE. Sou iniciante em usar computador(incrível!!!), mas gosto de fazer as coisas muito certinhas e o pessoal aqui de casa tira um sarro de mim só por que quero gravar minhas músicas com nomes certos…sou assim o que vou fazer…se você poder me ajudar agradeço.
    Obrigada pela atenção e fiquei surpreendida pela sua resposta tão rápida.
    Rosana.

  9. Rosana,

    Onde você está vendo esses nomes errados? no rádio do carro? Você está corrigindo os ID tag dos arquivos mp3 (que normalmente são utilizados nos tocadores de música) ou só o nome do arquivo?

  10. Neto,

    Eu vejo os nomes errados na tv (através do dvd-player), eu corrijo o nome do arquivo na pasta na qual armazeno e no WMP que aparece o nome da música como vem do e-mule e não como já corrigida na pasta em que arquivo. Só que no último cd que gravei coloquei umas músicas que tinha de um cd original mais músicas que peguei no e-mule e mesmo o nome das músicas do cd original ficaram com a acentuação errada. Pelo que você está me explicando “acho” que o erro não é de como vem do e-mule ou de um cd que eu passe para o pc, talvez seja do B’ Recorder Gold 5 (só que o manual é em inglês e eu não sei se tem essa opção de configuração) ou como você disse no ID tag dos arquivos mp3 (que eu não sei onde ficam e como se corrige), até pensei que pode estar errada a configuração do sistema ou do teclado (tem alguma coisa a ver?). Eu tenho instalado o programa Nero Mas nunca usei, será que com ele seria mais fácil e eu poderia fazer configurações para esse problema? Desculpe-me por tantas perguntas, é que só você no momento se interressa e esta me ajudando. Obrigada,
    Rosana.

  11. Rosana,

    Acredito que o problema possa não estar mais nem na forma de baixar a música, nem na forma de grava-la e sim no seu DVD. Aparelhos deste tipo (DVD, rádio de carro, aparelho de som) não suportam (em alguns casos) caracteres acentuados, por isso eles são substituidos por caracteres diferentes.

    Senti esta mesma dificuldade no rádio do meu carro, que simplesmente não exibe as letras acentuadas. A forma mais fácil que encontrei para resolver o problema foi remover os acentos das palavras. Tá certo que também gostaria de ter minhas músicas corretamente apresentadas, mas nem tudo é perfeito ;)

  12. Neto,

    Eu também removi os acentos e o ç, mesmo assim as letras que possuem acentuação e ç aparecem erradas e o nome da música aparece totalmente errado…mas como você disse: nem tudo é perfeito. Agradeço muito sua atenção e gentileza.
    Vou te amolar mais um pouco com duas questões:
    1º No tópico e-mule que você tem, eu mandei uma messagem dizendo que não consigo abrir as portas que você recomendou ( no 1º contato “através e-mail” que tive com você eu te enviei como está instalado o meu modem) não sei como abrir essas portas. Meu irmão me deu esse pc instalado com windows 98, um amigo de meu marido instalou através de um cd o windows 98SE, quando tentei instalar o speedy através do cd que eles enviam não deu porque faltava um ítem do windows 98SE, como esse “amigo” não estava com o cd em mãos ele instalou o modem através do seu modelo. Será que é por isso que eu não consigo abrir as portas do e-mule?
    2º O pc tinha 4 gb de hd e 64 de memória, travava toda hora e não podíamos armazenar quase nada. Então um outro “amigo” instalou um hd de 20 (que é o que o sistema suporta) e duas memórias de 128, só que aí surgiu um novo problema: ele não conseguiu tranferir os dados do hd de 4 gb para o de 20 gb…..ele tirou a gaveta de disquete (porque não usamos) e intalou de novo o hd de 4, então ele explicou que o hd de 4 fica sendo o mestre e o hd de 20 fica sendo o escravo (segundo suas palavras), ficou de arrumar um programa chamado GHOST para copiar tudo do de 4 para o de 20 e assim mudaria o comando sendo o de 20 o mestre e o de 4 o escravo ( estou esperando isto há 20 dias e nada) infelizmente existem raras pessoas que nos ajudam de boa vontade ( apesar de eu ter pago para ele fazer estas tranformações).
    Você tem uma idéia do que posso fazer nestes dois casos?
    Sabe Neto, eu sei que você é uma pessoa ocupada e deve ter muitos outros afazeres e coisas mais importantes do que estas coisas que estou te perguntando ( principalmente por eu ser uma pessou inexperiênte em informática e precisar de informações muito detalhadas de como fazer as coisas). Te fiz mais duas perguntas, mas sinceramente se você não responder não irei ficar triste, pois sei que já tomei muito de seu tempo e já estou muito contente por você ter me atendido e ter sido muito atencioso e educado.
    Agradeço muito a sua atenção e se não der pra gente se falar mais, muito obrigada por tudo e um grande abraço( virtual ) em forma de agradecimento.

  13. Rosana, quanto ao E-mule seu ADSL deve estar em modo bridge (com o IP válido no seu micro) ou redirecionando algumas portas para seu micro, as liberações variam de modem para modem e em alguns casos não são simples de serem realizadas, acredito então que no seu caso a forma mais fácil de faze-lo funcionar adequadamente é colocando-o em modo Bridge. Bem, o ghost é utilizado para fazer imagens de HDs, acredito que seja a melhor (e mais fácil) forma de resolver isso. Outra opção é efetuar a reinstalação do windows no HD de 20GB e copiar os dados do de 4Gb para o de 20Gb, mas também não é uma coisa fácil de se resolver.

    Att,
    Neto.

  14. Fiz a instalação do arquivo dll e registrei porém não aparece o ícone e nem mudou nada na tentativa de assistir videos com legenda no media player 9. Existe alguma outra configuraçao que possa dar conflito? Tem outra opção ou recurso de fazer nova tentativa?

  15. Mano, te devo uma
    Antes eu conseguia ler a legenda no Media Player, só que instalei um codec maluco, e depois que desinstalei ele não leu mais legenda

    brigadão, cara! você salvou minhas legendas!

  16. OI!
    Bom…..fiz exatamente o q vc descreveu,mas qndo abro o WMP ocorre um erro …
    VSfilter Syntax error at line 3977. O q fazer?
    Já tinha tentato instalar pacotes de codecs e tive o mesmo problema com o VSfilter!
    Sou novata nisso e preciso mto de uma ajuda!!!
    Obrigada

  17. ola estou com uma pequena dificuldade olha a dois dias que eu baixo musica no emule
    e a hora de abrir ela não abre , aoparece uma mensagen dizendo paramim ir no painel de controle e procurar em opções de pasta mas eu ja fui la fucei em tudo mais não adiantou
    se alguem souber por favor mi ajudem des de ja eu agradeço fiquem com DEUS !!!

  18. Neto estou com um problema.

    Coloco cds originais no drive do pc, abro o wmp e ele não aparece o nome das músicas.
    Aparece só faixa 1, faixa 2 etc,…vc sabe o que está acontecendo?

  19. Eliandro,

    Com CDs originais, o WMP procura o nome das faixas em um banco de dados mundial (CDDB). Para isso você deverá estar conectado na internet. Caso esteja e mesmo assim as faixas não são exibidas, possivelmente trata-se de um CD não cadastrado no CDDB.

  20. Não p´recisa nada disso para rodar legendas no media player de qualquer versão basta baixar e instalar o codec VobSub.

  21. Ola…
    fiz o que vc dice, tenho o klitle.codec
    fiz download do vobsub, do vcfilter…
    mais continua aparecendo VSfilter Syntax error at line 1116. O q devo fazer?

    desinstalei e instalei tudo!
    espero resposta!

  22. a respeito ao problema da rosana estou com o mesmo problema nao tem nada a ver com musica e sim todos os acentos do desktop ou programas em si sao exibido s sem acento totalmente errados e nao sei mais o que fazer ja tentei corrigor usando o teclado abnt ou abnt2 e nada e tbem opçoes regionais de entrada e nada
    se consiguir resolver o problema fico agradecido

  23. Excelente. funciona perfeitamente no WMP 10. valeu a dica.

  24. esse artigo é ótimo, funcionou mesmo, nem preciso do k lite. gostaria de saber se ha algum processo parecido para extenção avi., pra nao precisar instalar um pack inteiro.

  25. Funcionou perfeitamente no media player 11!
    apareceu a setinha verde e tudo mais… valew!!!

  26. valew véi!! fazia tempo q tava tentando ver filme com legenda no windows media player

  27. PERFEITO cara, muito obrigado!

    Caras, façam exatamente da forma como está descrito!!!
    Abração!

  28. Tutorial muito bem explicado, funciona perfeitamente, obrigado

  29. eu tenho o windows 7 como eu heide de fazer para adicionar legendas aos filmes ja tentei o real player o windows media player e nao consigo adicionar as legendeas sera q alguem me pode ajudar

  30. PessoALL, consegui resolver o problema q originou o post “vsfilter syntax error at line…” editando o arquivo da legenda ( .srt). Na minha máquina, não rodava em nenhum dos players (WMP, PowerDVD, MPC, etc), isto com k-lite instalado. A treta tá na sobreposição de tempo entre uma linha e outra da legenda, no meu caso era a linha 1850. Usei o Subtitle Processor 7.7.1 e mexi no início da linha indicada no erro, que na verdade creio ser o numero do frame. Adiantei de 5 a 10s em 2 linhas e voilá! Cabô com o erro! abc a todos!

  31. oi não consegui ! Descompactei o arquivo que vc mandou coloquei ele na pasta system 32, até ai tudo bem mas na hora de registrar não dá certo, diz que o arquivo não pode ser registrado! por que?

  32. Funcionou!!! Valeu aí! Achei q ia ter q baixar outro programa só pra poder carregar a legenda! Funciona no wmp10 tbm! Abraço!

  33. Basta nomear o arquivo da legenda com o mesmo nome do arquivo de video mas com extensão .srt q funciona! E claro, ambos estarem na mesma pasta. não precisa de tanto trabalho!

  34. Ótimo post.

    perfeito, deu tudo certo mesmo.

    Obrigada pela disposição em ajudar

  35. vlw cara, funciono perfeitamante. O meu sistema e Vista e WMP 10 entao deve funfa em gualquer um que fize os passos tudo certinho

  36. olá
    no prompt apareceu a seguinte mensagem:
    the specified module could not be found.
    o arquivo já está na pasta system32 e já tentei a opção copy release\…., como vc sugeriu em um dos primeiros comentários.
    o que devo fazer?
    desde já agradeço pela atenção.

Deixe uma resposta

O seu endereço de email não será publicado Campos obrigatórios são marcados *

*

Você pode usar estas tags e atributos de HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>